ADE 4.5.6. unter Windows 7

09.07.2018 | Ausrollen der beta-Version verschoben
Mehr dazu HIER.

  • Heute ist mir der Download von ADE 4.5.6. gelungen. Obwohl ich die neuere ADE Version zuvor installiert hatte, öffnet sich das Programm nicht, bzw. kann ich den URLLink.acsm zwar speichern, aber

    nicht zum Download des emagazines öffnen. Kann mir jemand einen Rat geben?

  • Am besten ist es, nur eine Version von ADE installiert zu haben, da sich die unterschiedlichen Versionen eventuell stören können.

    Was genau passiert, wenn du die Datei öffnen willst? Kommt eine Fehlermeldung?

  • Obwohl ich die neuere ADE Version zuvor installiert hatte, öffnet sich das Programm nicht,

    Vielleicht liegt's hieran:

    Den Ordner "%USERPROFILE%\AppData\Local\Adobe_Systems_Incorporate" löschen. Darin befindet sich in mehreren Unterordnern nur eine Datei "user.config", die defekt ist. Letztlich ist es diese Datei, die den Start von ADE verhindert. Wer vorsichtig ist, benennt die Datei "user.config" um, um zu sehen, ob es wirklich daran liegt. Ist aber sehr wahrscheinlich, wenn ADE vorher funktionierte und dann irgendwann sich nicht mehr starten ließ, vorzugsweise nach einem Absturz oder Abbruch.

    oder etwas detaillierter:

    In besagtem Ordner befinden sich evtl. mehrere Unterordner, die "DigitalEditions.exe_XXX" heißen, wobei das "XXX" jeweils bei Installation oder Upgrade von ADE neu ausgewürfelt wird. Hat man mehrere davon, können die alle gelöscht werden, denn diese wurden zuvor vergessen zu entfernen. In allen diesen Unterordnern findet sich in jedem Falle nur ein weiterer Unterordner "2.0.0.0", der dann besagte Datei "user.config" enthält. Schaut man sich das Änderungsdatum dieser Dateien an, wird lediglich die mit dem jüngsten Datum verwendet bzw. eben nicht verwendet, da der Inhalt (XML, also lesbar) nicht dem von ADE erwarteten Inhalt entspricht.


    Also genau diese Datei löschen oder umbenennen für den Vorsichtigen. Am einfachsten aber ist, wie eingangs gesagt, den gesamten Ordner "Adobe_Systems_Incorporated" zu löschen, da damit auch die ganzen nicht mehr beachteten Leichen entfernt werden. ADE legt dann die komplette Ordnerstruktur korrekt wieder neu an. Es geht auch keine aktivierte Adobe_ID verloren, da diese woanders abgespeichert wird. Lediglich die Voreinstellung, die Adobe-Bibliothek zu synchronisieren, geht verloren. Aber das läßt sich in ADE in den Voreinstellungen einstellen, da sich ADE dann ja wieder starten läßt.

  • Die anderen Versionen hatte ich vor dem Download deinstalliert. Wenn ich die Datei öffnen will, geschieht einfach gar nichts, keine Fehlermeldung.

    Am besten ist es, nur eine Version von ADE installiert zu haben, da sich die unterschiedlichen Versionen eventuell stören können.

    Was genau passiert, wenn du die Datei öffnen willst? Kommt eine Fehlermeldung?

  • Vielleicht liegt's hieran:

    oder etwas detaillierter:

    Vielen Dank für Deine Mühe mit der detaillierten Anleitung! Leider finde ich keinen entsprechenden Pfad zur userconfig. Als ähnlichen Pfad finde ich nur: OSDisk (C)/Users/Admin1~1.Min/AppDAt/Local/Temp. (Das Zeichen vor 1.Min. lässt sich hier - warum auch immer- nicht korrekt darstellen.)

    Programme und Daten befinden sich in meinem Rechner auf verschiedenen Festplatten.

  • Welchen Browser nutzt du denn?


    Ich empfehle Firefox, dann über die Einstellungen (Menu- Allgemein) festlegen, dass Firefox bei jedem Download nachfragen soll, wo er den Download abspeichern soll. Dann beim downloaden "öffnen mit" ADE auswählen.

    Nach dem ersten Download kann man unter Anwendungen dann für acsm Dateien angeben, dass diese immer direkt mid dem ADE geöfnnet werden sollen.

  • Welchen Browser nutzt du denn?


    Ich empfehle Firefox, dann über die Einstellungen (Menu- Allgemein) festlegen, dass Firefox bei jedem Download nachfragen soll, wo er den Download abspeichern soll. Dann beim downloaden "öffnen mit" ADE auswählen.

    Nach dem ersten Download kann man unter Anwendungen dann für acsm Dateien angeben, dass diese immer direkt mid dem ADE geöfnnet werden sollen.

    Ich nutze Firefox und habe die acsm-Dateien auch immer nur mit ADE zu öffnen versucht. Nur öffnet sich ADE sich eben gar nicht erst.

  • Lässt sich ADE überhaupt starten, also per direktem Programmstart, ohne ascm-file? Wenn nicht, dann ist vermutlich die ADE-Installation defekt und müsste komplett de- und neu-installiert werden.

  • Leider finde ich keinen entsprechenden Pfad zur userconfig. Als ähnlichen Pfad finde ich nur: OSDisk (C)/Users/Admin1~1.Min/AppDAt/Local/Temp. (Das Zeichen vor 1.Min. lässt sich hier - warum auch immer- nicht korrekt darstellen.)

    Programme und Daten befinden sich in meinem Rechner auf verschiedenen Festplatten.

    Der von Dir angegebene Pfad kann so nicht stimmen. Unter jeder halbwegs aktuellen Windows-Version (Vista, 7, 8, 8.1, 10) gibt es immer eine Umgebungsvariable "USERPROFILE", die z.B. im Windows Explorer mit "%USERPROFILE%" in der Adreßzeile benutzt werden kann und den Weg zum Profilordner des aktuellen Benutzers weist, also etwa "C:\Users\Benutzer" ("Benutzer" ist durch den Namen des aktuellen Benutzers zu ersetzen).


    In diesem Profilordner gibt es immer einen Unterordner "AppData\Local", in den alle Anwendungen einen eigenen Ordner mit Einstellungen erzeugen. Auch wenn diese Ordnerstruktur auf einer anderen Festplatte liegen sollte, so zeigt doch die Umgebungsvariable "USERPROFILE" immer auf den aktuell eingerichteten Pfad, dafür ist die Variable ja erfunden worden. Im allgemeinen liegt dies beschriebene Ordnerstruktur aber immer auf der Festplatte, auf der auch das Betriebssystem installiert ist, auch wenn die Daten woanders liegen. Das Betriebssystem ist normalerweise immer auf C: (der ersten Festplatte) installiert - außer es sind mehrere Betriebssysteme parallel auf verschiedenen Partitionen installiert, dann kann es auch ein anderer Buchstabe sein.


    Es kann jetzt sein, daß der Ordner "AppData" als Systemordner im Explorer ausgeblendet wird, je nach Einstellungen unter den Explorer-Ordneroptionen. Evtl. ist auch der Zugriff nicht für den normalen Benutzer erlaubt. Beides zu ändern, würde hier jetzt aber zu weit führen zu erklären - bitte dazu einfach mal nach "AppData-Ordner anzeigen" googlen (eine Fundstelle ist z.B. diese hier).


    Wenn der Ordner "AppData" sichtbar und doppel-klickbar ist, findet sich darin der beschrieben Unterordner "Adobe_Systems_Incorporate" usw. wie zuerst beschrieben...


    Sorry, das es jetzt doch etwas länglich geworden ist, aber wenn das hier gesagte nur wie böhmische Dörfer vorkommt, vielleicht mal jemanden fragen, der sich mit Windows ein wenig auskennt...

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von PeterSch () aus folgendem Grund: Tippfehler

  • Ich frage mich, wo das .Min herkommt und dieses (hier) nicht darstellbare Zeichen. Dabei habe ich schon etliche Sauereien mit Windoof Benutzerprofilen gesehen bzw. mich damit herumgeärgert, allerdings nur bei Computern in Domänen.


    Bleibt die Frage, ob Hulda den Inhalt von HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders hier mal als Screenshot einfügen kann und ob das zielführende Schlüsse zulässt...

    Das Prinzip, Komplexität mit noch mehr Komplexität scheinbar wieder beherrschbar zu machen, ist nicht nur das Geschäft von Juristen und Politikern, sondern auch das eines gewissen IT-Konzerns, der zudem den geistigen und sozialen Horizont gewisser Managertypen auf Kuchendiagramme einzuengen vermochte.

  • Lässt sich ADE überhaupt starten, also per direktem Programmstart, ohne ascm-file? Wenn nicht, dann ist vermutlich die ADE-Installation defekt und müsste komplett de- und neu-installiert werden.

    Nein, die ADE-Installation ist nicht defekt, es ist lediglich die vermurxte Datei "user.config", wie zuvor schon mehrfach beschrieben. Eine De-Installation und Neu-Installation von ADE bringt nichts, denn diese kaputte Datei "user.config" wird von der Deinstallations- und Neuinstallations-Routine nicht angefasst, also weder gelöscht noch neu und korrekt erstellt, wenn sie denn einmal da ist. Dabei spielt es keine Rolle, ob man dieselbe ADE-Version oder eine andere neu installiert. Man muß diese Datei wirklich von Hand entfernen!


    Kann sein, daß es mit ganz früheren ADE-Versionen anders war oder daß in zukünftigen ADE-Versionen dieses Verhalten geändert wird. Es wäre jedenfalls absolut simpel, in ADE einen Check einzubauen, ob die Datei einen korrekten (erwarteten) Inhalt hat und dann ggf. eine Warnung auszugeben bzw. am besten gleich den Inhalt richtig stellen. Aber es ist halt Adobe - das packen die nie, den Fehler werden die jahrelang mitschleifen, wie so viele andere...


    Also: Wenn ADE von jetzt auf gleich nicht mehr starten will, egal ob mit oder ohne ACSM-Datei oder Verknüpfung des Dateityps ACSM mit ADE, entweder im verwendeten Browser oder mit dem Windows Explorer, liegt es IMMER an einer kaputten Datei "user.config". Sobald diese gelöscht oder umbenannt wird, funktioniert ADE auch wieder und legt sofort eine korrekte Datei "user.config" an.


    Ich habe dies in einigen früheren Beiträgen doch schon mehrfach ausgeführt - ist das denn so schwer zu verstehen? Schwierig scheint mir hier in diesem Fall nur zu sein, diese Datei überhaupt zu finden ;-). Eventuell hilft hier eine Suche im Windows Explorer nach "user.config" - damit müßte diese sicherlich zu finden sein... Für solche Fälle habe ich übrigens das kleine Tool Everything installiert.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von PeterSch () aus folgendem Grund: Erwähnung von Everything ergänzt

  • Ich frage mich, wo das .Min herkommt und dieses (hier) nicht darstellbare Zeichen. Dabei habe ich schon etliche Sauereien mit Windoof Benutzerprofilen gesehen bzw. mich damit herumgeärgert, allerdings nur bei Computern in Domänen.


    Bleibt die Frage, ob Hulda den Inhalt von HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders hier mal als Screenshot einfügen kann und ob das zielführende Schlüsse zulässt...

    Ja, komisch ist das schon. Ich vermute, der angegebene Registry-Eintrag ist entsprechend - woher sollte die Umgebungsvariable sonst gesetzt werden? Vielleicht kann statt "%USERPROFILE%" auch "%LOCALAPPDATA%" genommen werden, ist etwas kürzer. Der Pfad zum ADE-Ordner wäre dann statt "%USERPROFILE%\Appdata\Local\Adobe_Systems_Incorporate" direkt "%LOCALAPPDATA%\Adobe_Systems_Incorporate", aber an dem grundlegenden Problem ändert das nichts, wenn die Pfade vermurxt gesetzt sind. Aber ich denke, dann würde Windows nicht mehr funktionieren - ein Benutzer braucht doch schließlich seinen Profilordner.

  • Warum kann man mt epaper mit ADE nicht scrollen wie früher mit adobe Reader und warum geht es mit der Bildlaufseite auch nicht ordendlich ?

    Hallo zusammen,bin Neuling,habe ADE 4.5 und Registrierung erledigt und wollte ein epaper auf meinem terra-pad downloaden.

    Dann kommt die Antwort : Download Error! Check if you have internet Connection or if device is activated.

    Was ist die Ursache?

    Danke und viele Grüsse,trutta

  • Ich frage mich, wo das .Min herkommt und dieses (hier) nicht darstellbare Zeichen. Dabei habe ich schon etliche Sauereien mit Windoof Benutzerprofilen gesehen bzw. mich damit herumgeärgert, allerdings nur bei Computern in Domänen.


    Bleibt die Frage, ob Hulda den Inhalt von HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders hier mal als Screenshot einfügen kann und ob das zielführende Schlüsse zulässt...

    Vielen Dank für die Bemühungen um Hilfestellung. (Ich konnte mich einige Tage nicht um dieses Prolem kümmern.) Hier ist der Pfad, den ich angezeigt bekomme: C:\Users\ADMINI~1.MIN\AppData\Local. In der Tat bin ich keine Windows-Spezialistin. Doch möchte ich ja eigentlich nur Bücher und Zeitschriften ausleihen...